HELP! ODrive not connecting!

Hey! I was doing some tests with my Odrive, still in v0.4.12 firmware release, when I decided I wanted to erase_configuration() on the Odrive. A few moments after sending that command through the odrivetool I powered down the Odrive and turned it on again but the Odrive wouldn’t connect with the running odrivetool session.

Tried turning on and off everything, including computer and Odrive, even a different cable, but nothing works. Nothing won’t appear even in the device manager. It is just if I were connecting an empty cable. I even tried connecting to a different computer

I am afraid maybe the Odrive got stuck in some process when I powered it off, and crashed horrible and won’t even properly restart.

Ever heard of anything like it? What can we do to fix this?

Really need to get this running again. Even though the board is version v3.6 do you think flashing firmware through a STlink would work? I see the STlinks pins are still there in the board.

I am ordering the cable through MercadoLibre Programador St-link V2 Mcu Stm32 Stm8
now to get it tomorrow. I am in Mexico City.

Do you think this could work? Thanks for your time.


Hi Valentin,

STlink flashing works for ODrive v3.6


Have you tried DFU mode?

1 Like

STlink flashing solved the problem. Thanks

1 Like