How to get the maximum speed?

Hi
The motor I use does not have the speed like this video.

ODrive will in general drive to about 75% of base speed, so my 100kv motor on 24V would reach 1800 RPM.
Since I use the motor at reduced speed(Reduction ratio 1:8), the speed will be 225 PRM.
But the current speed is only about 20 RPM.
What is the max speed possible?

My Environment

My config is as shown in the picture.


How to get the maximum speed?

According to your settings current_lim is set to 1. I think that will be the issue.

Thanks!
I set current_lim=3, so the current speed became about 60 RPM.
Because the vibration was large, I changed the following gains,
pos_gain=30
vel_gain=0.0002
pos_gain=0.5*10*vel_gain

But when I set current_lim=4, the motor started and then stopped.
I got the following error.
axis0 axis: Error(s): ERROR_DC_BUS_OVER_VOLTAGE
What parameters should I change?

Did you connect a brake resistor and configure it?

Oh, sorry, I made a mistake.
I got the following error.
axis0 axis: Error(s): ERROR_DC_BUS_UNDER_VOLTAGE

What is your power source? Can it supply current more than 4A?
Power wires and connections can be source of problem. More current makes more voltage drop on wires and connections

I use gimbal motor.
According to the website, current_lim is 4V, not 4A?

Note: When using gimbal motors, current_lim and calibration_current actually mean “voltage limit” and “calibration voltage”, since we don’t use current feedback. This means that if you set it to 10, it means 10V, despite the name of the parameter.

Hey Bump,

I was wondering If you we’re able to get any progress on this?
I’m having the same problem with my motors. Due to the high resistance of my coils I could only get it to work in gimbal mode (Getting started - Motor error 64).
All seems to be working fine but also at a max speed of around 60rpm, even though my motors are rated for 3000rpm.

Could this be something gimbal mode related?

Jasper,

If your motor has high resistance (and inductance?) it is probably designed for a much higher voltage e.g. industrial servomotors.

What sort of motor do you have?

Hi JasperJ
I had made mistake.
I had used “gimbal motor mode”, but I should have used “high current motor mode”.
Using correct mode, you will get beep.