Issue building devel firmware


Just got my odrive, trying to build the development firmware (as I want to convert a hoverboard based robot to it) and I’ve got some kind of issue with the toolchain I just cant find, I’ve tried it on a windows 10 and debian machine but keep getting the same result, as shown here. Any ideas?



Is there more error messages not shown in the screenshot? I see the tup error messages, but not the error given by arm-none-eabi-gcc itself.

There wasn’t, but I ran the command manually and think I might be onto something, looks like a slash has gone missing somewhere

i think its something to do with mixing / and \ slashes, if i replace the \ in the output filename with a / when I run the command manually it runs OK

try building in cmd rather than bash?

same tup error when running make from cmd (and powershell), however strangely if I run the command shown exactly in error in cmd manually it runs without problem…

strangely from CMD it is also creating the files just fine the first time around, even though it thinks it is not

no idea what the problem was, but i managed to build the firmware successfully by making a fresh ubuntu 14 VM and just replicating the steps Travis CI was taking to do the build tests. Something windows 10 build environment related I guess.

for any other noob’s reference who want the devel firmware and have any issues, the required steps were:
install ubuntu 14
smash this into terminal:

sudo -E apt-get -yq install libc6-i386 git
mkdir dl
git clone --depth=50 --branch=devel madcowswe/ODrive
git submodule update --init --recursive
export GCC_DIR=$HOME/dl/gcc-arm-none-eabi-7-2017-q4-major
export GCC_ARCHIVE=$HOME/dl/gcc-arm-none-eabi-7-2017-q4-major-linux.tar.bz2
export GCC_URL=
if [ ! -e $GCC_DIR/bin/arm-none-eabi-gcc ]; then wget $GCC_URL -O $GCC_ARCHIVE; tar xfj $GCC_ARCHIVE -C $HOME/dl; fi
export PATH=$PATH:$GCC_DIR/bin
export TUP_DIR=$HOME/dl/tup_0.7.5-0~16.04.york0_amd64
export TUP_ARCHIVE=$HOME/dl/tup_0.7.5-0~16.04.york0_amd64.deb
export TUP_URL=
if [ ! -e $TUP_DIR/bin/tup ]; then wget $TUP_URL -O $TUP_ARCHIVE; dpkg-deb -R $TUP_ARCHIVE $TUP_DIR; fi
export PATH=$PATH:$TUP_DIR/usr/bin
export DEPLOY=v3.5-48V
export CC=gcc

and find your firmware in Firmware/build/ :grinning:

1 Like