Issue regarding with cogging

I m currently working on BLDC motor.I m facing an issue of cogging . I tried to tune the gain parameters also I m using odrive in velocity control . What should I do?

In order from most recommended:

  1. Adjust velocity control gains for better behaviour
  2. Adjust encoder.config.bandwidth higher to improve the dynamic response of the velocity estimator
  3. Enable the Anti-cogging Feature
1 Like