Motor doesn´t move in initial Calibration

Hello everyone,
I have some issue with Odrive V3.6 56v. It is my first project with odrive. I use one small motor JK42BLS02 from china with hall sensors, 8 poles, torque inertia 0.04, rated current 3.3A, rated speed 4000 rpm and rated voltage 24V.

Every time I try to calibrate motor, it goes to fault state MOTOR_ERROR_DRV_FAULT, or if I increase the calibration voltage and current it goes to MODULATION_MAGNITUDE . Sometimes If i changed these two values I took ERROR_PHASE_RESISTANCE_OUT_OF_RANGE. It wasn’t able to measure resistance and inductance in MOTOR_CALIBRATION. No motor move, no beep.

Gate driver does not have any error. It is only in motor and I am able to clear this error. Resistance between two wires connected to odrive is 1,19 Ohms (all wire combinations are the same).
I run now from 12V Pb battery with voltage around 12,4V (I tried connect another one with 22V, but there was no difference).

Another problem is that encoder is_ready property is still false after settings. With encoder I tried Polarity calibration and Phase calibration.

I made this settings:
odrv0.axis0.motor.config.motor_type = MOTOR_TYPE_HIGH_CURRENT
odrv0.axis0.motor.config.pole_pairs = 4
odrv0.axis0.motor.config.calibration_current = 1.5 (tried from 0.5 to 7)
odrv0.axis0.motor.config.resistance_calib_max_voltage = 4 (tried from 2 to 10)
odrv0.axis0.encoder.config.cpr = 24
odrv0.axis0.motor.config.bandwidth = 1000
odrv0.axis0.motor.config.mode = EncoderMode.HALL
odrv0.axis0.motor.config.calib_scan_distance = 50 (I tried 150 too)

I set the controller to a ramped velocity control.

Could you please help me with proper settings? I am not able to run this motor.
FW version in Odrive is and I use odrivetool v0.6.1.post0 on Windows.

After some tests and next reading about motor settings I set the motor_type to GIMBAL (I found that the motor is Delta type, so phase resistance is higher than 1 Ohm).I tried to motor calibration again. Now calibration gives no error, but still there is no move and beep. If I try to calibrate encoder polarity, offset or phase, there is axis error = INVALID_STATE. Is it possible that the encoder causes these problems?

Please follow the Hoverboard Guide for instructions to configure HALL sensors. Hoverboard motor and remote control setup guide — ODrive Documentation 0.5.4 documentation

Motor won’t beep in GIMBAL mode.