Motor failing after calibration and entering closed loop control

#1

After I turn on my Odrive 3.5 and go through calibration and enter closed loop control if I then use pos_setpoint the motor soesn’t respond but there are no errors. If I then try to turn the shaft of the motor the motor fails with errors. I have just updated the firmware from the original version and updated odrivetool, the motor worked before the update with the original firmware. Is there some incompatibility in my settings? How do I clear configuration?

In [112]: odrv0.axis0.requested_state = AXIS_STATE_FULL_CALIBRATION_SEQUENCE

In [113]: odrv0.axis0.requested_state = AXIS_STATE_CLOSED_LOOP_CONTROL

In [114]: dump_errors(odrv0)
axis0
axis: Error(s):
ERROR_CONTROLLER_FAILED
motor: Error(s):
ERROR_CONTROL_DEADLINE_MISSED
encoder: no error
controller: Error(s):
ERROR_OVERSPEED
axis1
axis: no error
motor: no error
encoder: no error
controller: no error

This is the configuration

In [120]: odrv0.axis0.config
Out[120]:
startup_motor_calibration = False (bool)
startup_encoder_index_search = False (bool)
startup_encoder_offset_calibration = False (bool)
startup_closed_loop_control = False (bool)
startup_sensorless_control = False (bool)
enable_step_dir = False (bool)
counts_per_step = 2.0 (float)
watchdog_timeout = 0.0 (float)
step_gpio_pin = 1 (int)
dir_gpio_pin = 2 (int)
lockin:
current = 10.0 (float)
ramp_time = 0.4000000059604645 (float)
ramp_distance = 3.1415927410125732 (float)
accel = 20.0 (float)
vel = 40.0 (float)
finish_distance = 100.0 (float)
finish_on_vel = False (bool)
finish_on_distance = False (bool)
finish_on_enc_idx = False (bool)

#2

I seemed to have solved my problem. I erased the configuration with erase_configuration(), the motor still exhibited the same problem. I then retuned the vel_gain etc. It seems this version of the firmware is more sensitive to vel_gain tuning which was .0005 now is .00032.

Increase pos_gain by around 30% per iteration until you see some overshoot.

Could someone please tell me how we test for overshoot here?

The motor is hobbyking propdrive v2 4248 650kv