Motor Wont Turn Using Input_pos

Hi All,

I am working on setting up my Odrive for the First time. My motor is the following:


The motor will turn just fine for calibration. But when I tell it to say turn 100 using input_pos the motor wont turn. I got it to turn the number of rotations if I tried manually turning the motor shaft to get it stated. Almost like the motor what not able to over power from the rest point.

Any assistance would be greatly appreciated. If you need any info please let me know and any commands I may need to run to get that info. Sorry as I am still learning but I am happy I got this far without help.

As discussed on discord, this is a 2-pole-pair motor with a 2400 cpr encoder, so

odrv0.motor.config.pole_pairs = 2
odrv0.encoder.config.cpr = 2400

That should be enough to get started. IIRC you said this worked, but you had overspeed and current violation errors. This is likely because the motor is very high kV and the acceleration is very fast - using the vel_ramp or one of the other filtered position modes should help with this :slight_smile: