No USB connectivity to Odrive in either RUN or DFU Mode

First time long time. Sorry if this isn’t in the right place. I’ve searched for similar topics but none have addressed my issue.

Basically I’m getting started with my Odrive and trying to connect a salvaged hoverboard motor but I can’t get the odrivetool to recognize my board. When I run odrivetool it says 'Please connect your Odrive".

Some things I’ve tried:

  • I’ve waited quite a while (>>30s)
  • I’ve tried both Ubuntu and Windows 10 with basically the same results.
  • Running either lsusb or ‘dmesg | grep tty’ shows nothing related to the Odrive. Nothing in device manager on windows. When running Zadig on Windows, nothing related to Odrive shows up in the drop down.
  • I’ve read on other posts that if the board isn’t recognized in RUN mode to power off and switch to DFU mode and try to re-flash firmware. But with the dip switch (SW1) set to DFU, I still get no response at all on the port using any other above options.
  • Nonetheless I tried running ‘odrivetools dfu’ and the tool seems to hang on 'Waiting for Odrive…", as I would expect if there was no connection. Running Zadig with the board switched to DFU also yield no results in the drop down.
  • For the record, I connected an FTDI Adapter (first usb device I spotted on my desk) to the same usb port on my laptop and it’s recognized with no problem. Issue seems to not be with the port.
  • I’ve tried multiple cables (including the one shipped with the odrive).
  • I’ve looked for damage on the board and nothing’s apparent. I did solder caps to the hall wires as recommend on the hoverboard getting started page but they’re not shorting or anything and I seriously doubt they have anything to do with this issue.

As you can see I’m grasping at straws. The only thing I haven’t tried is to flash using an STLink but I’m skeptical it would work if the device isn’t even recognized in DFU (besides, I don’t have one, rather not buy one unless I’m reasonably sure it’ll work). I have a gut feeling I’m still missing something simple though

My setup:

  • Benchtop PSU, 24V (fwiw, it pulls about 2mA in DFU mode and 32mA in RUN mode, both with no motor/hall connected)
  • Ubuntu 18 and Windows 10
    Odrive v3.6, 56V
1 Like

Thank you for taking the time to try all these options and also write up what you have tried. I think you have covered all the troubleshooting steps we would recommend.
For reference, and for others reading this, the main method we recommend is: trying various PC’s and USB cable while SW1 is set to DFU and checking device manager or lsusb, also verifying that the PWR green LED comes on with applied DC power.

Given that you see a power draw difference in RUN and DFU mode, I would guess that the STM32 is actually working ok, and there is likely some soldering defect on the USB connector. If you have the equipment you can try using a fair bit of flux and hitting the connector’s data pins/pads on the “back” (pcb side) with hot air.

Of course we are happy to send you a replacement if you prefer (feel free to try the hot air first even if you decide to get a replacement). If so, please email with a link to this thread and your order number.