No usb device showing


#1

I have a new ODrive 3.5 48v and I’m working in win10 with anaconda.

I have connected all of it apart from my encoder as that has a female connector on it atm. I get a nice green power light.

I followed the getting started guide and got to plugging in the usb and nothing. I’ve stolen a different cable from a echo, still nothing, restarted the computer zip, Ive tried conecting the usb then the dc and the dc then the usb this isn’t clear to me in the guide. I’ve checked the psu it’s giving 22v. I switched the lower dip to dfu.
I just get no recognition in windows that I’ve attached anything, no device missing drivers, no ding you’ve plugged something in.

Have I got a brick or is there something else I can do?
Thanks
Tim
Ps I do have a linux pc running LinuxCNC in the garage that I’ll take it and test it with tomorrow.


#2

Hi Timmy, have you made sure you have the drivers installed?

this bit of the getting started.

Use the Zadig utility to set ODrive driver to libusb-win32.

  • Check ‘List All Devices’ from the options menu, and select ‘ODrive 3.x Native Interface (Interface 2)’. With that selected in the device list choose ‘libusb-win32’ from the target driver list and then press the large ‘install driver’ button.

hope this helps: :grinning:

Regards Jerry


#3

In addition to Jerry’s suggestion, it could also be, if your drivers are ok, that the odrive might not of been flashed or lost its firmware.

Flashing it using an ST-Link would fix this. I occaisonally lose the firmware in the odrive (maybe due to a slow discharge on switching off the psu, I dont know)


#4

It was the point of setting the driver that I fell over in the getting started guide, there is no odrive in the Zadig list, i’m assuming because windows hasn’t even detected a connection.

image

is there any way of knowing if the issue is missing firmware without an STlink? I dont really want to buy one to find that its not that?

Thanks
Tim


#5

Ah and i’ve checked the usb connection an Arduino connects quite happily.


#6

Did you check Device Manager?


#7

I’ve checked device manager, device and printers, ive plugged into other windows and Linux computers I don’t get anything. the computer just doesn’t know anything has been plugged in.

I’ve bought a ST-Link and have spent a good 1.5h trying to work out how I do this, is there not a good guide this seems to be a known issue, it appears i have to build my own firmware?

I’ve got VSCode installed with the all the exstentions listed in the developer guide, scratched my head working out where tasks are? final worked out that CTRL+Shift+B should do that, but i get an error.

Please help, i’m literally lost, even google goes off on a tangent on me when i try and search for make not being recognised.


#8

You don’t need to build the firmware, you just need to follow these steps:

  1. Turn off the power to the ODrive
  2. Set the bottom DIP switch to DFU.
  3. Follow the Device Firmware Update instructions.

If you can’t get that to work, find me on the ODrive discord and I’ll guide you.


#9

I have tried to see you in discord, but i’m in the UK so assuming ill have to come back later for that.

Thanks for the firmware link I hadn’t thought it would be in the odrive tool section, Its much simpler not having to build my own firmware. Though the windows process still seems complicated, i reverted to a linux box. I got to

“wrote 262144 bytes from file ODriveFirmware_v3.5-48V.elf in 10.878982s (23.532 KiB/s)”

but i still get nothing over USB “lsusb” doesn’t list any new device, either when the dip is set to normal or DFU mode. Odrive tool doesn’t find anything though i’m assuming thats inevitable if the os isn’t aware its there.


#10

That means the firmware was written successfully, so the chip seems to work. Can you try a different USB cable?


#11

Ive tried it with the cable from an Echo and the one that came with the Odrive I don’t get anything, Ive plugged an Arduino in using the cable that came with the Odrive and I lsusb gives
“Bus 006 Device 027: ID 2341:8036 Arduino SA Leonardo (CDC ACM, HID)”


#12

Any idea what i have to do?
is it dead?


#13

What Arduino board are you using? Also, I would recommedn uninstall Arduino IDE and reinstall it back on.


#14

Hm I guess it might be dead then. Email us at info@odriverobotics.com and we can initiate a replacement.