Not getting any rotation or voltage when trying to start

Hey,
So I am trying to run a rather tiny motor (proof of concept first) and i am not able to make the motor move at all. I have even checked to see if there is any voltage across two of the leads and nothing is getting put out… also checked current and of course also 0.

I have a version 3.5 board 12-48v dc & the AMT102-V, Running about 16v dc through it. And the motor can go to like… 20ish.

I have actually tried with two motors, the other one was a much larger motor and 48v dc, i was using a 48v dc power supply for it however. It also was not getting any flow from m0 or m1.

So I can get through all the steps of the “Getting Started” with no problem. But when it comes time to try “odrv0.axis0.requested_state = AXIS_STATE_FULL_CALIBRATION_SEQUENCE”. I get nothing.

I have no idea what I could be doing wrong. I have tried checking other configs, resetting the board back to factory and restarting a few times… And Im not sure what else to do.

Oh also sometimes when I go to just check that all is still good, I try the “odrv0.vbus_voltage” and it says its exactly 12.0. When it should be like 16.6456345734637356 or so. It does work when take the power off and do like a super hard reset, but not from a reboot.
Actually, i tested it again (was just left “running” after i tried “odrv0.axis0.requested_state = AXIS_STATE_CLOSED_LOOP_CONTROL”) and the voltage test said 12.0 again… It its like its timing out or something.

Is someone able to help me please?
Thanks!

Please try checking your errors: dump_errors(odrv0)

In [2]: dump_errors(odrv0)
axis0
axis: no error
motor: no error
encoder: no error
controller: no error
axis1
axis: no error
motor: no error
encoder: no error
controller: no error

Well, I have done more digging.

After a odrv0.reboot() the odrv0.vbus_voltage command returns 12.0 always. Even though after a hard restart, Or right from power up it will say the actual number. So im not too sure what that is…

But also, the odrv0.axis0.motor.config.phase_inductance & odrv0.axis0.motor.config.phase_resistance both return 0.0. I took a multi meter and tested against the three leads and the resistance is about 0.3.

So, Any ideas?

Thanks.

Okay, I have made sure that everything is up to date.
But still not getting anything from the leads.
Acting the same, and still no Errors when running the " dump_errors(odrv0) ".
Something else I can check or is this board shot??
Thanks.

So, Ive ran through the basic steps again just to show that it has values.
Then tried to run " odrv0.axis0.requested_state = AXIS_STATE_FULL_CALIBRATION_SEQUENCE ", and I get nothing out of the board. And also no errors.
Then I tried " odrv0.axis0.requested_state = AXIS_STATE_CLOSED_LOOP_CONTROL " and also no errors.
And I do have the motor in M0. I have also tried M1.

Any ideas because this is really frustrating that its not working and has no errors.

Thank you!

Very curious. Can you do me a favour and run the following commands?

odrv0.erase_configuration()
odrv0.axis0.requested_state = AXIS_STATE_FULL_CALIBRATION_SEQUENCE

And see if you get anything?

Hey, I have ran both of those commands.

Ive done the erase two times per motor to try and reset all to make sure I didn’t enter in something.

And the full calibration sequence doesn’t move nor has moved / sends no wattage.

odrv0.axis0.requested_state = AXIS_STATE_CLOSED_LOOP_CONTROL also does not send out a current of any sort / make the motor “harder” to turn.

I can try again though and will get back with results!

Thank you.