Not wanting to flash or boot up?

I have been working with the Odrive for a few weeks now and it has been working fantastic! I built a little system using a pixy camera and Arduino that tracks objects and move a laser. Everything was working fine for a while (a few weeks) then the odrive seemed to stop responding.

When you plug in the motor and encoder it won’t startup, the green light turns on but nothing else happens . I tried two different power supplies, no difference, two different motors, no change. I had a problem similar to this a while back and all I did was re flash the firmware and everything was good, so I tried that, and this is what happens.

Ideas?

Some things to check:

  • Unplug the programmer from the computer USB and back in again, and also power cycle the ODrive (make sure green light switches off).
  • Is the microcontroller getting warm if you leave the ODrive on?
  • Double check the programmer’s connection to the ODrive, including GND. Try some other wires jumper wires.

Let me know how it goes, cheers.

So I tried a new set of jumper cables, no change, I had already tried re started and unplugging / plugging in the o drive / usb several times, including restarting the computer. After the oDrive has been being plugged in with the light on for several minutes I can not feel any change in temperature on any of the chips. Maybe I manage to burn something out? I have a multimeter should I check something with that?

Also I tried unplugging everything to see if there was a difference, no change.

The non-thermal is to see the orientation etc.

I think the next thing to try is replacing the STLink. I can send a replacement one to you if you like?