Odrive 3.5 motor does not move/beep at all?


#1

Hi,

I am trying to use my odrive 3.5 followng the – otherwise nicely written – documentation, with odrivetool.

I do have an odrive detected, i do get the correct vbus_voltage as expected.

the symptom is the always the same.

When i run
odrv0.axis0.requested_state = AXIS_STATE_FULL_CALIBRATION_SEQUENCE
nothing happens. no beep. no movement.

I observe the following

In [13]: odrv0.axis0.error
Out[13]: 1

(note: the value is there, even right after booting)

(which translate to AXIS_ERROR_INVALID_STATE (in the code, the description say “an invalid state was requested”)

When i set it to 0, it immediately comes back to 1 error.

In [14]: odrv0.axis0.error = 0

In [15]: odrv0.axis0.error
Out[15]: 1

I tried changing to batteries (12V and 36V). I tried with a power supply. I tried with motors SK3 5065 236 and 600p chinese encoder. I tried with SK3 6374 149 and CUI encoder. All connectd to M0.
I tried changing to another odrive 3.5 board (i got 3 48V units)
=> To no avail. always same behavior

What do i do wrong ?

(i have not reflashed the boards => should I?)


#2

Try:

  1. Double check you have a motor and encoder on channel M0 connected
  2. Reset the ODrive config: odrv0.erase_configuration(), odrv0.reboot()
  3. Try again: odrv0.axis0.requested_state = AXIS_STATE_FULL_CALIBRATION_SEQUENCE

Let me know how it goes


#3

it worked.

looks like odrv0.erase_configuration() saved the day

i was wondering how to restore to factory defaults, but you even answered that one before i got the chance to ask :smiley:

great!