ODrive calibrates OK, then fails to spin motor, but no errors

I just acquired o-drive board for work and tried to set up a motor. I am using a flipsky 6374 190kv motor.

The motor comes with build-in 3 hall sensors and I also added an AS45047P sensor.

The motor and hall sensors work, I can properly control the motor with hall sensors using VESC tool.

Now the o-drive board.

Using the built-in sensors the motor turned, successfully calibrated, I saved the results.
Then I tried all controls, position, velocity, etc. without success. The board started throwing errors.
I re-calibrated a few times, tried again to simply turn the motor, same result – nothing, Some times the board had errors, some time it didn’t have errors but no motor action either way. At that point I reset the parameters and switched to AS45047P. The motor calibrated, I tried to turn using velocity, nothing.
Checked for errors, no errors.

At that point I can conclude the board is defective.

Two questions:

  1. Has anyone encountered a similar issue?
  2. Where / how can I return the board? I am not a hobbyist, this is work related and I cannot afford to tinker with apparently pre-production hobby-grade board. I was under the assumption it’s a production grade board, I guess I was wrong. Nowhere on the website is a place I can initiate an RMA.

I would appreciate any input.

Thank you. Valentine

Are you sure that you put ODrive into the correct mode?
You might need to set controller.config.input_mode = INPUT_MODE_PASSTHROUGH before it will do anything.

  1. if you need to return it, email info@odriverobotics.com with your order number etc.

Mr. Owen,

Thank you for your input, I will try your suggestion.

I did already submit an RMA request to Mr. Weigl, yes. I had the board randomly fail calibration on the same motor when I tried reproducible calibration and then odrivetool would suddenly hand, refusing to send commands to the board, ramping up machine CPU to 100%. My setup is quite sound, I am a professional working in a lab in a reproducible environment performing multiple board and motor evaluations from different manufacturers, not a hobby setup. The level of odrive documentation and support is rather targeted towards a hobbyist/tinkerer board and not commercial / industrial grade. Plus the firmware being rather complex made it impossible to really tell what’s gone wrong. I am sure there will be many others who find that board/level of support acceptable and willing and happy to work with. It is rather unfortunate as this board was initially a top contender for my job.


I have never had ODrivetool hang like that. Maybe you have an issue with Python - are you running on Windows or Linux?

What commands did you use, what errors were being thrown?

I too have worked with industrial servo drives from the likes of Moog, Elmo, Kollmorgen etc. and of course ODrive is not the same as those - i’d say it’s halfway between a hobby ESC and an industrial servo. But I think that is reflected in the price, and the types of motor and encoder that it pairs with.
If you went ŧo Kollmorgen support and told them you were using a Flipsky motor with a £15 encoder, they would laugh and tell you to buy a ‘real’ motor from them for £3000. :wink:

So true. Actually their pulse encoders are £3 Honeywell ones. And Flipsky motors are actually pretty good considering. Kollmorgen can laugh as much as they want, while Flipsky laughs all the way to the bank.

I am running a clean Windows 2019 Server, imaged only for odrive testing purpose.

Haven’t gotten to your suggestion yet, have other tasks. Will return to testing later today and let you know. Either way I should not be getting random calibration errors when my calibration sequence and software and hardware setup is fully reproducible. I have no problem sharing the exact parameters, I am not doing anything proprietary, it’s an evaluation effort. I’ve got a bunch of other boards and motors to evaluate.