ODrive not recognized, even after re-flashing

#1

I received my ODrive v3.6 (24V) a few weeks ago, and successfully had it spin a motor in sensorless mode, using odrivetool.

I shelved the unit for a weeks while I tinkered on my mechanical setup. Today, I pulled the Odrive back out, plugged in power and USB and… nothing. No ODrive USB device shows up in Windows device manager, nor in Zadig. odrivetool never detects the connection of the odrive.

I have successfully reflashed the board, both using DFU and using an STLink. With DFU, I had to set the dipswitch to DFU, at which point the SMT32 Bootloader USB device does show up in Windows. The update seems to go smoothly, except it times out at the end while waiting for the device to re-appear. Upon flipping the switch back to RUN and power cycling, still no device in windows.

What could possibly be wrong?

#2

This might work if you haven’t tried already.

  • Download STM32 ST-LINK Utility (link)
  • hook up STLink
  • Target -> erase chip
  • File -> Open file (load ODrive firmware)
  • Target -> Program
#3

Thanks a lot for the suggestion!

Unfortunately, I just tried it and no luck :frowning:

#4

You could try a different cable, different USB port or different PC.

#5

Good news: It’s fixed!

Bad news: it’s a weird one, and I wasn’t able to reproduce.

I decided to disconnect my motor leads (M0) from the board as well as the brake resistance. I noticed that some of the screws have been somewhat loose. After powering the board back up (no leads attached), it showed up! I then re-connected all the leads (M0 and resistance), and everything seems back to normal.

I tried reproducing the issue by purposefully making loose connections and fiddling with wires, but did not have any success. Weird.