Odrive stoped working after flashing


I’m pretty new to working with the Odrive and run into some trouble with my Version 3.6 24V one. I’ve been working with it quite successfully with different motors (Hoverboard and Drone Motor) but after some issues during calibration I’ve decided to flash my Odrive.

I’ve been working on a Mac through the Terminal and followed the " Upgrading firmware with a different DFU tool" chapter in the docs.

However, I got following message:

Afterwards I was unable to continue and can’t seem to connect to the Odrive anymore- what am I missing- anyone got an Idea?

I’ve already ordered an ST-Link for my other Odrive for some reasons, im planning on trying out with this one once it arrives . Would that help?

The screenshot you show is for the regular DFU process. Further down is the “Upgrading firmware with a different DFU tool”. Try that.

Fixed it with some tweaking and doing what you recommended, thanks!

For anyone with a similar problem, here’s how it worked for me:

I followed the doc “Upgrading firmware with a different DFU tool” , and used this workaround, as the download of the gcc-arm-none-eabi-74 didn’t quite work out with the recommended code:

brew tap PX4/homebrew-px4
brew update
#list available
brew search px4
#latest working ver as of this post
brew install gcc-arm-none-eabi-74

When I got to the “dfu-util -S 207632994D4B -a 0 -s 0x08000000 -D ODriveFirmware_v3.6-24V.bin dfu-util 0.9” code I got this issue:
dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
dfu-util: No DFU capable USB device available

So I disconnected the Odrive from the PC and power, switched it manually to dfu mode and reconnected. Afterwards it downloaded successfully, I disabled the dfu mode and the Odrive connected normally in the odrivetool!

Sorry all the rambling but as a beginner myself I feel like this might help someone else :wink:

1 Like