ODrive USB connections


I’ve working on a project where we are re-engineering a robotic arm, originally designed and made by others. It uses 3 ODrive boards to drive 5 motors in total.

They have trimmed the ODrive board PCBs because they wouldn’t fit where they wanted them. :man_facepalming: :adult:

There’s enough of the + and - terminals to solder wires too, so I’m not too concerned.

However, as you can see the USB socket has been removed - there was a USB cable wired up to TP1 TP2 and TP3. On one of the boards they had resistors wired between the PCB and USB cable. Could this be because resistors R1 and R3 had been damaged?

Ideally we’ll reuse the existing ODrive boards, but just to make sure we don’t have issues with the USB connection.

Thanks in advance.


I can’t see your picture but… :scream:

Sounds like these poor ODrives have been butchered.
Do they show up as USB devices? (e.g. in dmesg -w on Linux)

Yes there are normally 22R resistors in the USB data wires, I think this is either to do with ESD protection or EMC.

Take a look at the schematic here: (the last released schematic was for 3.4, but all that has changed are some component values for filtering, so I’m told)

Be careful not to pull any tracks off the board… :grimacing:

Thanks for the quick reply.

Horribly butched. I think maybe they damaged the resistors on one of the boards, hence adding new ones in.

I’ve tried up loading the photos. Just saying ‘Processing’ any ideas?

Processing: 2021-12-20 16.54.49.jpg…
Processing: 2021-12-20 16.54.49.jpg…

Weird. No, I have no idea what is going on there…
I just tried and I am able to upload PNG anf JPG images (via screenshot / clipboard, or via upload button - I’m on Linux/Chromium fyi)
It may be because you’re a new user and don’t have upload permissions yet - so it might need one of the mods to hit approve on your pictures.