Odrive usb no longer showing up

I have been using my odrive for several weeks now and this morning the usb is no longer showing when using lsusb and of course odrivetool does not connect. The green power light is on. Using Ubuntu 18.04.5 LTS. Also tried on a windows 10 machine and the usb does not show up there either using the zadig.exe tool. Help.

Does it show in lsusb (or dmesg) when you put the switch to DFU mode and cycle power?
Have you tried a different cable?

Have tried 3 cables, different ports and different computers. What appears to be the dfu switch (SW1) is covered with what appears to be kapton tape as shipped by odrive. Looking at it thru a magnifying glass it appears to be in run mode. Tried to move it with the tape on, but it didn’t readily move so I didn’t push it. No indication of any damage to board anywhere and checked voltage at 5v and 3.3 volt and both are reading the appropriate voltage. Decided to remove the tape and put it in dfu mode. It now shows up as a STM device in dfu mode. When I move back to run mode it does not show up.
What next?

It’s covered with tape because you don’t normally need to use it, except in case of a ‘soft-bricked’ board ie the loaded firmware is not working.
If the switch is in the DFU position, then the chip boots automatically to the DFU bootloader to allow you to program it over USB. Normally a working firmware can simply be asked to go to DFU mode by the odrivetool.

Since it’s working in DFU, you can now flash firmware with odrivetool dfu as normal. However do note that it will not be able to backupo and restore your config. You will have to restore it manually.

1 Like

Your suggestion was right on. 1)Changed the switch to dfu mode. 2)Cycled power and ran lsusb and a new STM device appeared. 3)Ran odrivetool dfu which reloaded the firmware. 4) Changed SW1 to run and cycled power 5)Started odrivetool which connected to the device. Problem solved…Thank You.