ODrive v3.5 doesn't connect


We have a connection problem on ODrive v3.5 48v version. It worked very well previously, but this morning a high current flow into the board for very short time (11A for about 2 seconds), it doesn’t show up on odrivetool anymore.

The ODrive is connected with resistor, and we tried to use DFU tool to re-flash the firmware, but it doesn’t find ODrive. Also running lsusb (we use Linux) the computer cannot find it. Then we tried flash with ST Link, but it gave this error:


We checked the cable connections multiple times, it seems correct. Do you have any ideas about this problem? We’ve also tried to flash v3.5 with ST Link before, it also ran into problems. Is it possible to flash newer version this way?

Any help will be appreciated!

A good way to check if stm32 is still alive is to use STM32 ST-Link utility (windows only) and try Target->connect. If it says something about read protection, you can use Target->Option Bytes and set the read protection level to level0. If it simply fails, the stm32 is probably dead.