ODrive v3.5 not connecting in Windows


#21

Glad you got everything working!

To answer this question:

The default for the 48V version of the firmware should be dc_bus_overvoltage_trip_level = 51.84. I don’t know how you ended up getting the value that’s intended for the 24V version.


#22

I’m having the issue of Windows (Anaconda) not recognizing the ODrvie 3.5!
Using Zadig, I did install the usb driver and it does shows up in my device manager!

However, odrivetool in Anaconda does not find the odrive!
Searching in the community comments, I found that some people resolved this through disabling Odrive CDC (which is what I have done, per the snapshop above), some resolved the issue through flashing the device using the ST tool, which is what I did, but still no hope!
All I get is Anaconda asking me to connect the odrive!

I also tried a different computer. The issue in that one was even worse! :slight_smile:
On that computer odrivetool wouldn’t run. It would give the error message of:
[TerminalIPythonApp] WARNING | File not found: ‘C:\Users\Username’

BTW, I’m not modifying the firmware or anything! Just trying to run odrive for the first time, using Windows and Python!

Any help is appreciated!


#23

Can you try running odrivetool in verbose mode, and let us know if there is any additional information?
odrivetool -v


#24

Hi,

Thanks for the response. That command gives the message of “no response - probably incompatible”.
here what I see when I use that command:


C:\Users\install>odrivetool -v
ODrive control utility v0.4.6
Waiting for ODrive…
USB discover loop
Please connect your ODrive.
You can also type help() or quit().

ConfigurationValue 1
InterfaceNumber 2,0
EndpointAddress 3
EndpointAddress 131

EndpointAddress for writing 3
EndpointAddress for reading 131
Connecting to device on USB device bus 0 device 2

no response - probably incompatible
USB discover loop
USB discover loop
USB discover loop
USB discover loop


#25

BTW, I tried using arduino for running the device and spinning a motor (for the first time), but that also did not work!

It does the initial tuning (pressing 0) and the motor turns by a fraction of a turn. And also it does read the encoder. But, when I press “s” for “test move” it does nothing!

I hope you can help, as I have not been able to do anything with the purchased ODrive yet!

Thanks


#26

Can you try flashing the new firmware version 0.4.7?