Odrive won't connect to computer


#1

Hello,

I’ve been working with my Odrive for 3 days now. I was able to calibrate my motor and encoder and save my configuration; however, yesterday when I turned it on, it did not run the startup calibration. It will also not connect to the computer. Looking at the forums, it was suggested to flash the latest firmware onto the board. I have a 24volt version 3.5. To do this I flipped the switch to dfu and my computer recognized the board. I typed odrivetool dfu into the anaconda terminal. At this point it starts the flashing process. However, it keeps failing and giving me the same error message (a photo is attached). If there is any advice about what is happening or how I could fix it, it would be greatly appreciated.


#2

So, a quick update. I was able to flash the board using the " Upgrading firmware with a different DFU tool" instructions. The program told me that the flash was successful. I still, however, cannot get my computer to recognize the device in run mode. What I’m confused about is why it was working the other day but not now.


#3

Does the ODrive show up in device manager when you power it on and connect USB?


#4

So, to update, I finally was able to get it to connect to my computer. And yes, I was not able to get the ODrive to show up in my device manager when I turned it on. After I re-flashed the board it was still not showing up. I’m not really sure what I did differently to get it to connect finally, but me and my labmates think it might be that our switch between RUN and DFU is not sturdy.

Thank you for responding though