OdrivePro encoder and controller not found

Hi, I’m trying to configure an Odrive Pro to control a bldc motor with an hall effect encoder but i have some problems. I already did it on the normal Odrive but it seems that some config commands are not the same for the Odrive Pro.

I tried to configure the Odrive Pro with the Odrive Pro documentation but in result, my encoder and controller are not found.


I think, I made some mistakes on the encoder config. I don’t really understand what should I chose for :

odrv0.axis0.config.load_encoder = EncoderID.HALL_ENCODER0
odrv0.axis0.config.commutation_encoder = EncoderID.HALL_ENCODER0

I replaced encoderID.HALL_ENCODER0 by ENCODER_MODE_HALL but I’m not sure of it.

Pro is very different. Please follow the Beta docs word for word.

You’re supposed to just copy & paste these values.

Thanks for your reply. I tried to copy past the values in the Beta docs but I received these errors :

I suspect that’s because it wants “EncoderID” and you’re giving it “EncoderId” with a lowercase “d”.

I receive the same error when I use EncoderID :

In that case I’m sorry but I don’t know what to recommend. I’m here in a similar situation to you: the product I bought doesn’t work, I have no intuition as to why not, and there’s absolute radio silence when I come here to ask about it.

Maybe someone else who bought an ODrive Pro might chime in and help you. Otherwise I think we’re on our own.

Are you using the ODrive Pro odrivetool? pip install --upgrade odrive --pre

Thank you, it’s why it didn’t work. Errors desappeared and i can use the command lines.

1 Like