Oh no odrv0 disappeared

Hello,
I got this message “Oh no odrv0 disappeared” and the Odrive stop working once the I send the the AXIS_STATE_FULL_CALIBRATION_SEQUENCE command or any other movements commands then the Odrive will reconnected again once the motor stops ?
Same results with versions 3.6 &3.5 with macOS and windows
And if send AXIS_STATE_CLOSED_LOOP_CONTROL , i can stop the motor only by sending stop command from the Arduino connected to the Odrive using UART
Any advice?
Note: The Odrive will works fine if i fully control it from the Arduino

Hello Ozzo.nebras,
Can you check if there is any kind of USB error in the system log when ODrive disappears?

1 Like

Can you also try a different power supply and a different USB cable?
How are your motor phases wired? Is there some possibility of a ground loop? Can you try with a known working motor/encoder pair?

1 Like

I am using MacBook pro with USB-C to USB-A adapter, when figure out the problem i tried another adapter and the problem still there, both of the adapters convert one USB-C to three USB-A


Today I tried a new adapter which has only one input and one output and it solve the problem