One of four ODrives not connecting via USB

we ordered an ODrive 3.6 / 56V a few weeks back for testing purposes. Overall a good experience.
Now, for a side project, we ordered three more of the same model.

After unboxing them, I was planning to update the firmware, restore a config, set them up in general …

Everything went smoothly for two of them - but the third one doesn’t connect to odrivetool (no errors) and can’t be found on my list of USB devices. They are being run from a 24V line coming from a bench top power supply.

So basically, they are all three fresh out of the box and got the same treatment without having anything attached besides a power supply and a USB cable.

Is there a way to have them switched against a different one?

I read about flashing the firmware manually. I don’t feel too comfortable with this since I never worked with STM microcontrollers. Will trying this void my warranty?

No, flashing a new firmware (i.e. with odrivetool dfu) is a supported feature will not void the warranty, it is not possible to ‘brick’ the ODrive if you flash code from the ODrive repository.

Please check that it shows up as a USB device if you set the switch to DFU mode before applying power. You should be able to flash it with odrivetool dfu from that state.

1 Like

Thank you! Flashing from odrivetool requires the board to be recognized, I guess.

I just tried flipping the switch over from “RUN” to “DFU” before connecting the board to power and USB. Sadly, the board still doesn’t show up in my USB devices like the other ones.

I also tried bridging GPIO6 to GND in addition to flipping the switch to DFU. No success.

Any more ideas?

  1. Please ensure the green LED is on when power is applied (24V)
  2. Check the 5V and 3.3V rails for appropriate voltage
  3. Please look closely at the USB connector for any shorts

Hey @Wetmelon, your last point might actually be a thing - I am not sure. Maybe you can confirm that.

When I look closely at the micro USB port, I can spot like three and a half solder pads. The one on the far left seems to be fully buried under the left sided solder pad that holds the USB port in place. The one on the right is at least connected to the right pad for securing the connector in place - I checked this with a multimeter.

So - two out of five pins are connected to the USB port housing.

Looking at the schematic, there should be four “free” ones - while the fifth (left) sits directly on the GND (?) plane.

If that’s the problem, I might be able to fix it with some solder wick or flux and a smd heat gun, but I don’t really want to try unless I get some kind of official permission from ODrive to have the board replaced if it still doesn’t work or if I break something in the process.

Bildschirmfoto 2021-10-14 um 17.18.40

1 Like

Yeah I think the one on the right in the picture needs to be separated from the ground.

Haha yes, I’ll vouch for you. It’s clearly shorted, and the board arrived broken. Go for it!