Phase resistance out of Range error - nan

Hi, I am using the a nanotec motor (DB59L048035-A - Brushless DC motor | NANOTEC) wiht my ODrive. However, when I run the calibration sequence I get the MOTOR_ERROR_PHASE_RESISTANCE_OUT_OF_RANGE error and the phase resistance reads nan. I have set the motor config parameters as follows:

odrv0.axis0.motor.config.current_lim = 16
odrv0.axis0.controller.config.vel_limit = 75
odrv0.axis0.motor.config.calibration_current = 10
odrv0.config.enable_brake_resistor = True
odrv0.config.brake_resistance = 2
odrv0.axis0.motor.config.pole_pairs = 3
odrv0.axis0.motor.config.torque_constant = 0.10000000149011612 
odrv0.axis0.motor.config.motor_type = MOTOR_TYPE_HIGH_CURRENT
odrv0.axis0.encoder.config.cpr = 4096

On increasing resistance_calib_max_voltage, calibration_current, etc, I get the MOTOR_MODULATION_ERROR or the MOTOR_ERROR_SYSTEM_LEVEL.

I would really appreciate some help here. Thank you!

Make sure your resistance_calib_max_voltage is below 50% of your bus voltage, and calibration_current can be achieved at that voltage with your expected resistance. If it’s still failing, then check your connections.

That worked!! I just increased it and it started spinning a little! Thank you!!

1 Like