Problem in full calibration sequence


#1

Still problems, I cannot get past one anticlockwise revolution…

it is not not completing command

odrv0.axis0.requested_state = AXIS_STATE_FULL_CALIBRATION_SEQUENCE

So, as advised by Oskar,

I configured and saved the correct settings for my AMT10 encoder. I am using a pair of D6374 150kv motors, and a 3.5 ODrive. I entered

<axis>.encoder.config.use_index =True
<axis>.requested_state = AXIS_STATE_ENCODER_INDEX_SEARCH
<axis>.encoder.config.pre_calibrated=True
<axis>.motor.config.pole_pairs=7
<axis>.motor.config.motor_type=MOTOR_TYPE_HIGH_CURRENT
<axis>.config.brake_resistance=0.47
<axis>.encoder.config.cpr=8192

then
odrv0.save_configuration()

then in odrivetool

ODrive control utility v0.4.0.post9
Please connect your ODrive.
You can also type help() or quit().

Connected to ODrive 376436543137 as odrv0
In [1]: odrv0.axis0.current_state
Out[1]: 1

In [2]: odrv0.axis1.requested_state = AXIS_STATE_FULL_CALIBRATION_SEQUENCE

In [3]: hex(odrv0.axis0.motor.error)
Out[3]: '0x0'

In [4]: hex(odrv0.axis0.error)
Out[4]: '0x41'

I have a copy of my_config.json file if required

Please help me out. I have spent more than a couple of days on this.
Thanks in advance,
James


#2

OK, as advised by Oskar, do not include .requested_state = AXIS_STATE_ENCODER_INDEX_SEARCH
SO…

while setting up the configs, I ran these commands again:

odrv0.erase_configuration()
odrv0.reboot()
odrv0.axis0.encoder.config.use_index =True

odrv0.axis0.encoder.config.pre_calibrated=True
odrv0.axis0.motor.config.pole_pairs=7
odrv0.axis0.motor.config.motor_type=MOTOR_TYPE_HIGH_CURRENT
odrv0.config.brake_resistance=0.47
odrv0.axis0.encoder.config.cpr=8192
odrv0.axis0.requested_state = AXIS_STATE_FULL_CALIBRATION_SEQUENCE

then
hex(odrv0.axis0.motor.error)
returned ‘0x0’
hex(odrv0.axis0.error)
retrurned ‘0x41’


#3

Also
In [24]: hex(odrv0.axis0.encoder.error)
Out[24]: ‘0x2’


#4

Do not set these. Then I think it should work.


#5

ARGGGG watch your cables… label them. My sensor cables were swapped !
All was OK after that

Sorry guys!
\wa
wa
wa
waaaaaaaa