Problem installing odriver in Linux (Ubuntu)

Our RPi3 is running:
Linux Ubuntu 16.04
Python 3

Goal: Get odrive tool up to configure BLDC motors
Issue: Error is thrown as follows…
Command “python egg_info” failed with error code 1 in /tmp/pip-install-ejoicyzy/matplotlib/

When following the getting started method on Odrive page seen here:

Under section downloading and installing tools:


  1. Install Python 3.
  2. Install the ODrive tools by opening a terminal and typing pip install odrive
    (note: we also tried this with same error code 1…$ sudo -H pip3 install odrive )

We have search high and low for a fix so we can install odrive but without much luck getting past this error. In Linux bin folder no odrive is listed yet.

Has anyone else had this issue when getting started with installing odrive on Linux system?
Thank you kindly,

This resolved our error in Linux termial:
sudo apt-get install python-matplotlib

I have same issue and have both python-matplotlib and python3-matplotlib. Any other options?