Reflashing Odrive v3.6 56V with USB connectivity problems

Hi everybody,

I have an odrive board 3.6-56V.
It stopped working without any reason. Now I can’t connect it to the PC using the USB cable and odrivetool. Simply, the USB interface of my PC doesn’t see the Odrive board (I’m using Linux).
The PWR led of the board is on and I also checked the voltage on pins to be as expected, so I’m assuming the board is not broken.

I was considering the possibility to reflash the board, since I read on a topic that it could solve the problem.

I have a ST-LINK V2 and I’d like to use it to reflash the board. I first edit the Firmware/tup.config file and set


then, I ran make command inside the Firmware directory.
I connected SWD, GND and SWC on the J2 connector to SWDIO, GND, SWCLK on the ST-LINK V2.
Then I tried to run make flash and I obtained the following message:

board version: v3.6-56V
Firmware version 0.5.4-dev (fw-v0.5.4-54-g24e034a4)
 [     ] 100%                                                                  
openocd -f interface/stlink-v2.cfg  -f target/stm32f4x.cfg -c init \           
	-c 'reset halt' \
	-c 'flash write_image erase build/ODriveFirmware.elf' \
	-c 'reset run' \
	-c exit
Open On-Chip Debugger 0.10.0
Licensed under GNU GPL v2
For bug reports, read
Info : auto-selecting first available session transport "hla_swd". To override use 'transport select <transport>'.
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
adapter speed: 2000 kHz
adapter_nsrst_delay: 100
none separate
Info : Unable to match requested speed 2000 kHz, using 1800 kHz
Info : Unable to match requested speed 2000 kHz, using 1800 kHz
Info : clock speed 1800 kHz
Info : STLINK v2 JTAG v35 API v2 SWIM v7 VID 0x0483 PID 0x3748
Info : using stlink api v2
Info : Target voltage: 3.166623
Error: init mode failed (unable to connect to the target)
in procedure 'init' 
in procedure 'ocd_bouncer'

make: *** [Makefile:66: flash-stlink2] Error 1

Do you have any suggestion on which could be the USB connectivity problem or how to solve the make flash error message?

Thank you,

Hmm… curious. It should work with the STlink 100% of the time, as long as the STM32 isn’t dead. Double check the wiring on that mabye?