Running in Sensorless Woes


#1

Howdy,

Spending my Christmas break playing with the O-Drive! v3.5-48v firmware v0.4.1-dev. I am having trouble getting going in sensorless mode. I am carefully following the instructions but am stuck with setting this parameter:

odrv0.axis0.sensorless_estimator.config.pm_flux_linkage

So checked other posts that this was missed on an early release of the firmware in August and am hoping it would be fixed in the latest update. So I tried to run the firmware update ~$ odrivetool dfu and I get a bunch of errors:

_sre.SRE_Match’ object is not subscribable - About 50 times

Then an exception “could not find any fimware release for this board version”

Does anyone know what I can do to fix this?

Thanks!

Scott


#2

Hi Scott, try this

Hope this helps
Regards Jerry :grinning:


#3

Thanks Jerry, but still stuck. Those are the same instructions that I have been following.

When I enter:
odrv0.axis0.sensorless_estimator.config.pm_flux_linkage

I get the error ‘RemoteObject’ object has not attribute ‘config’

I think this is a problem with the firmware, but I cant update the firmware with the dfu tool. Still stuck.


#4

Hi if you have been following the written process, and still NO luck; you might wish to join the discourse chat.

Others have found this very useful.

Regards Jerry :grinning: