Serial Timeout Issue

So are you precalibrating the motors or having them autocalibrate on turn on?

Also, are you editing the code using vscode or eclipse?


I’m using the autocalibration at startup. But I have no load now, should change in future.
My OS is Windows 10 and my tool is VScode.

Greetings / Zennix

Thanks Zennix,

I will check into setting up VSCode to modify the source code. Although, I think I am going to start up a similar project using python until there is a fix for the issue.


@wayneStock Are sending serial over the USB CDC interface, or over UART?

I was using the USB CDC Interface.

There is bug we are working on fixing which means that there may be collisions between the two interfaces.
Can you try to disable the native interface in device manager?

I will look into it, hopefully by the end of the weekend.

Thanks for looking into it.



first test with devel branch -> the communication breaks.
second test with deactivated native device in device manager -> communication breaks too.
third test with commented out parts of “else if (cmd[0] == ‘w’) { // write property” in the ascii_protocol.cpp -> communication runs without problems.

Greetings / Zennix

I also attempted to test the serial communication again by disabling the native interface. It appears that the communication still breaks. I decided to lower the rate to about 10 calls a second; and it still breaks after a bit.


Okay thanks for trying. I have made a separate issue on github to track this.

Can you guys help me out with some details that will help me to reproduce the issue here? What is your OS, what commands are you sending? using what program? Other details? Thanks!

Hi Oscar,

OS = Win10.


Set about 30 Repetitions.

Greetings / Zennix

Do you have the source for this program, so I can dig in in case I need to?


It’s in C# VS2017.

Greetings / Zennix

I will work on getting you my program as well.

I am using a Windows 10 Machine with C++ Qt 5.10

What’s the status on this?

I’ve been struggling with faulting serial on my Ofrive for a few weeks and finally realized that it’s on the ODrive side.

Anyway…any quick fixes? I’m talking UART via arduino and using the example program as a guide.

Is there a way to make it wake back up? It crashes my robot and I have to do a reboot.

I haven’t tested switching to say Idle mode and then back? Does anyone know if there’s a hack work around? Or some command that can re-establish the serial connection.

Did you solve the problem?

I did not. Waiting see if there any updates that fix the issue.

As far as I know, there is still an issue with the serial when using r and w. I tried with the most recent firmware this past weekend to no avail.


Has the serial timeout issue ever been solved? My project isn’t progressing and I’ve been focusing on other aspects…but solving this soon would be helpful.

I was having some USB/Serial COM issues with a different board (the OpenCR1.0) and I think I solved it by disabling the FIFO buffers in the WIndows USBCOM port settings. You may want to try that.

1 Like