[SOLVED] 2nd Hooverboard BLDC not responding to .vel_setpoints

#1

We have upgraded our two rotary encoders to Omron E6B2-CWZ6C (1000 p/r) from Odrive Doc’s rotary example (400 p/r) Our cpr is now 16000. (1000 p/r * quad * 4:1 gear ratio to couple encoder to wheel

) We have two BLDC motors from hooverboard. One motor configs fine with gains at: .pos_gain=1, .vel_gain =0.000625, .vel_intergrater = 0.000313. This first motor runs well with .vel_setpont=20000. However the second motor with same gain settings produced a 2 second spin that slowly rotated only 1/4 turn and stoped. The issue is I have tried to tune gains on second motor from .pos_gain=1, .vel_gain =0 to 0.005, .vel_intergrater = 0 to .0025 with the best results at same gain values as first motor. The first motor works great. The second motor is being a dog. Any ideas why when the Phase and Inductance resistance values are very close for both motors? I tried to increase current to 20 A however the result is
the same. Thanks for chiming in . Happy Friday

0 Likes

#2

Hi,
Our two wheeled rover ran this code below
abort_after = 10 # 10 seconds

my_drive.axis0.controller.current_setpoint = 3
my_drive.axis0.controller.vel_setpoint = 5000
my_drive.axis0.controller.pos_setpoint = 100
my_drive.axis1.controller.current_setpoint = 3
my_drive.axis1.controller.vel_setpoint = -5000
my_drive.axis1.controller.pos_setpoint = 100
start = time.time()

while True:
delta = time.time() - start
if delta >= abort_after:
my_drive.axis0.controller.current_setpoint = 0
my_drive.axis0.controller.vel_setpoint = 0 # rate of wheel A
my_drive.axis0.controller.pos_setpoint = 0
my_drive.axis1.controller.pos_setpoint = 0
my_drive.axis1.controller.vel_setpoint = 0 # rate of wheel B
my_drive.axis1.controller.pos_setpoint = 0
break

0 Likes

#3

SOLVED -
Gains for Axis1 now set as the same as Axis0 and both wheel are moving at the same rate finally. I dont know why these gain would not work before trying many other .vel_gain setting. Working gains settings: .pos_gain=1, .vel_gain =0.000625, .vel_intergrater = 0.000313

0 Likes