[SOLVED] Odrivetool from CAN branch doesn't have can config fields


I saw in this thread that in order to use CAN on my ODrives I have to set them up first, and to do so I have to checkout the CAN/feature branch from the repository. If I run git status I see I checked out the right branch, and if I git pull it says I’m up to date.

Unfortunately though, if I run ./odrivetool from the /tools subfolder, I still can’t use odrv0.axis0.config.can_node_id. The property can_node_id just doesn’t exist.

I wonder if perhaps I also have to update the firmware… If so, I’ve no clue how to do it without a hex file.

Or what else could be the issue?

Thanks a lot, as usual.

I have figured it out myself using this page: https://docs.odriverobotics.com/developer-guide
In order to make a .hex-file, I ran the make file which can be found in ODrive/Firmware. This .hex-file is created in a folder called build. This .hex is used to flash a custom firmware on the ODrive.

I hope I can help more people with this!

1 Like