Tab does not work on odrivetool console (0.5.4)


I’ve been encountering strange behaviours in one ODrive (hardware v3.5, running 0.5.4 firmware, and 0.5.4 Python odrive library).

  1. After a few hours running, the control routines from the Linux computer running it consistently end up in shaky torque control behaviours, as if the frequency of communication from computer to ODrive dropped from ~30 Hz to ~2 Hz. The result is that after some increasing earthquake motions, ODrive runs into an error shut-down.

  2. No matter if I saved configuration (I believe correctly, as than motor can run), after shutting down the ODrive and restarting it, it complained every time about encoder phase not found.

  3. Inside odrivetool, “tabbing” for autocompletion only worked for odrv0, axis0/1, but not any further. So, for instance, pressing tab at the state below did not give any reaction from the console, which is considerably annoying considering how many commands are to be given for configuration and testing:
    In [1]: odrv0.axis1.

Given all the above were strange to me, I decided to uninstall and reinstall the odrive python library with pip. I still cannot “tab”, and I’m afraid the rest of problems won’t be solved either.

I also saw that according to documentation there is a version 0.5.5, but it does not seem available from pip (0.5.4 is the latest of 0.5s). I also understand that 0.6 and onwards are intended only for ODrive Pro.

So, basically, I’m running the latest software that exists, but I’m encountering tons of issues and malfunctioning. :frowning:

Can you cast some light on the issues above? I understand the first 2 may require further details, but at least “tabbing” should work properly, and if not you may know why it doesn’t.

Thank you.

You’re actually not on the newest firmware or software! 0.6.3 is the newest python lib (supports 0.5.5), and 0.5.5 is the newest firwmare. But I’ve seen this before and it’s always been a PC side issue. I think we had a memory leak in fibre at one point, sometimes it’s USB issues, etc. But I suggest upgrading to odrivetool 0.6.3 and firmware 0.5.5

pip install --upgrade odrive
odrivetool dfu

Hello @Wetmelon,

The website seems pretty clear that 0.6.3 isn’t meant for ODrive 3.6 though. This is even 3.5. If I click on that link it sends me to 0.5.5.

Is that info only for the firmware, then?
I’ve to say that version numbering of Python matching firmware exactly is a little confusing :slight_smile:

You then confirm that the version number of Python library and firmware can mismatch?

Yes sorry it’s only for firmware. As of 0.6.3, it is backwards compatible to 0.5.5, and we intend to keep backwards compatibility at least for some foreseeable future.