Tarot 4108 Not Moving After Firmware Upgrade

If anyone running into the same issue…I realized that my settings were messed up because the new firmware change quiet a few things under the hood!
So changing my vel_gain and vel_limit made everything work again!

These are the settings that are working for my Tarot 4108

odrv0.axis0.motor.config.pole_pairs = 11
odrv0.axis0.motor.config.torque_constant = 0.0217631578
odrv0.axis0.motor.config.resistance_calib_max_voltage = 3.0
odrv0.axis0.controller.config.vel_limit = 100
odrv0.axis0.controller.config.vel_integrator_gain = 0
odrv0.axis0.controller.config.vel_gain = 0.01

After upgrading the firmware of my Odrive V3.6 Yesterday, I can not bring my Tarot 4108 back to work!
I installed the latest Odrive Tool and also the latest firmware!

After flashing the firmware and realizing that things are screwed up I ran
to start fresh…

I ran the Getting Started and everything works as stated, the only thing I am having to change is up the
odrv0.axis1.motor.config.resistance_calib_max_voltage = 3.0

I set the pole pairs and torque constant
odrv0.axis1.motor.config.pole_pairs = 11
odrv0.axis1.motor.config.torque_constant = 0.0217631578
My motor is being rated as 380 KV

And let the values for my motor and encoder as stated in the defaults
odrv0.axis1.motor.config.motor_type = MOTOR_TYPE_HIGH_CURRENT
odrv0.axis1.encoder.config.cpr = 8192

odrv0.axis1.requested_state = AXIS_STATE_FULL_CALIBRATION_SEQUENCE
odrv0.axis1.requested_state = AXIS_STATE_CLOSED_LOOP_CONTROL

Runs without error but when I set a position
odrv0.axis1.controller.input_pos = 1

It exits into

To try and get this to work I set
odrv0.axis1.controller.config.vel_limit_tolerance = 0

And used different stiings for odrv0.axis1.controller.config.vel_limit

But no luck…the motor is just not moving the slightest bit!!
How could I possibly solve this?

1 Like