Tup: error: the following arguments are required: file

I’m having trouble compiling firmware on my pi, and I don’t know what file isn’t being found or specified.

Can somebody tell me if this is something I have to specify when calling “tup?” I this an issue with a config file somewhere?

If it’s helpful context, I only edited one line of can-simple.cpp. Hopefully, this story ends with the
“Encoder Estimates” message sending controller.electrical_power instead of encoder.pos_estimate. Thanks in advance!

Can you do a tup --version?

Interesting… same error as just calling “tup”

After more research, I was on version 0.3. Pip wasn’t getting me the latest version, so I uninstalled with pip and installed version 0.7.8 with
sudo apt-get install tup

I’ve got a whole new error here. Progress! Any clues as to what’s going on? Now it’s the same problem Jamil84 had back in September.

python3 --version is 3.7.3
python --version is 2.7.16

Gotta run make instead of tup, because make executes a python script to pull the version from git and dump it to a version.c file.

1 Like

This makes me happy. I re-cloned the repo, re-installed git-lfs (that I swear was installed before), and called make. Great success - thanks!

1 Like