Two Dead ODrive V 3.6 Boards?

I recently purchased 2 ODrive V3.6 24V boards. My development machine is Ubuntu 18.04 Linux machine. Neither of the boards shows up as a USB device in Linux (lsusb does not show the device, dmesg does not show the device being detected on USB, it shows nothing when the device is connected.)

= I am powering them (for now) with a 13.5V power supply.
= I have tried another, different Ubuntu 19.04 Linux machine.
= The green power light comes “on” on both boards when power is applied.
= Though I originally had motor + encoder + resistor connected I have tried with no other connections to the board (no motor, no resistor, no encoder)
= I have swapped out 2 different USB cables.
= On one of the two boards I have switched it into DFU mode.
= It shows up just fine in Linux as a DFU / usb device.
= I have flashed released firmware images for v0.4.11, v0.4.12, and v0.5.1 to the board with DFU
= I have put the switch back into run, and cycled power and => still nothing.
= I have flashed released firmware images for V0.4.11 and v0.4.12 on it with ST-LINK programmer and cycled power and => still nothing.
= I have left the other board alone and just tried to see if it showed similar symptoms.

I’m not sure what else to try at this point.

Thanks for any advice…

The two boards seem identical in behavior regardless of what I do. With the switch in DFU mode (or on STLINK) it is like the processor is there and everything is fine (I’ve done a ton of STM32X development on Linux for years) and when I put the switch back to RUN it is like the processor just locks up on startup or something.

[Edit] I read the other posts on this topic as well, but they didn’t quite seem to cover what I’m seeing exactly so I started this thread.

This is most similar to the problem posted (unanswered) a year ago:

Following up on this post. I spent the rest of the evening trying different things and I ended up swapping out my power supply.

I switched to a battery pack to power the oDrive even though my benchtop supply seemed to work fine and output reasonable voltages 13.5V on a voltmeter.

On this battery pack the oDrive comes up and talks over USB in my setup and I even got a motor to move ever so slightly.

So, apparently it is very sensitive to (wild guess here) some kind of noise on the power supply? I don’t have conclusive evidence, but the power source seems to really matter and the battery pack is slightly lower nominal voltage ~12V than the benchtop PSU.

I’ll follow up as I use them more to see if this persists.

Interesting, yes, it seems that for some configurations the ODrive USB communication can be very sensitive to noise. Make sure you don’t have any big ground loops, and that you’re using quality USB cables with chokes.

I also meet the same problem.
I use a 48V adjustable power to suppy my odrive and found no usb odrive in my RPi.
When I powered odrive again, none startup I saved in odrive works(like startup_calibration)
So, It seems that odrive not boots normally.
After I swap an other power supply, my odrive can work on usb.
what I wander was how to choose a power ‘good’ enough?