I am using the ODrive Robotics D5065 - 270kv motor with the CUI AMT212B-V-OD encoder and the ODrive S1 driver. The 3 motor phases as well as the provided 50W2RJ resistance and a 12V power supply are connected in the right spots in the screw terminals of the driver. I have succeeded at least once the configuration of the driver up to the closed loop control part through the odrivetool. But on another day, I tried once again to enter closed loop control mode. I got the error NOT_CALIBRATED so I tried to do odrv0.axis0.requested_state = AxisState.MOTOR_CALIBRATION first, but I keep getting the error UNBALANCED_PHASES. I measured the resistance between the phases with a multimeter and I get the same resistance (approximately 0,5 ohm) between every couple of phases, so I should not be getting this error right? What could be the cause of this and will I need to change the motor?

Hi there,

0.5 ohms sounds high - though this may just be the multimeter’s minimum resolution.

You can try increasing the calibration current from the default of 10A to around 20A or 30A if possible – the unbalanced phases detection is proportional to calibration current, so sometimes noise can cause issues.

This could also be wiring - would you mind posting some pictures of your setup? Particularly how the wires are connected to the motor and ODrive.

I changed the calibration current to 20A first and it didn’t work. Then I changed it to 30A and instead of UNBALANCED_PHASES, I got CURRENT_LIMIT_VIOLATION, so I thought it would be a good idea to check the current_soft_max and current_hard_max even though the setting of those values comes after the motor calibration in the odrivetool setup documentation. So considering that I am using a power supply with a 12V 30A 360W output, I set the current_soft_max to 20A and current_hard_max to 25A. I did the motor calibration after that and it worked! I just find it weird that setting the current limits comes after the motor calibration in the odrivetool setup documentation because I would have been able to avoid the problem I had,

Hm, it shouldn’t have to be that high. I’d take a good close look at your wiring if possible. That being said, great to hear it worked! Note in general power supply current != motor current - you can set motor current higher and use the new active power limit feature.

1 Like