USB and UART connection not working

HI! My Odrive v3.6 has been working well but suddenly, my PC is not able to recognise the Odrive board. I’ve tried also to communicate with the board via UART using an Arduino, but it didn’t work aswell.

When I connect the power source to the Odrive, the pwr led turns on, and also the 5V and 3,3V pins give the correct voltage.

My concers are about the microcontroller, maybe it’s bircked. I say this because the only problem remains in communication, since I tested other options.


Hi Joaquim, I recommend flashing the controller via odrivetool dfu. Failing that, you can try one of the other dfu options (see If that doesn’t work, try to flash it with an STLink v2.

Thanks for the reply!

I’ve tried to flash the controller via odrivetool dfu, but at some point it doesn’t go further as the Pc waits for Odrive connection and it doesn’t detect it. I’ve also tried to flash it via DfuSe app, but the Pc keeps not recognising the board.

Maybe my last opportunity is try to flash the controller via STLink v2. Will it work?

I have been having the same issue with my board! It started yesterday when I tried to use odrivetool dfu to update the board firmware, since a few of the calibration commands were not being recognized (torque_constant) was returning an attribute not found error).