USB Connectivity Problems


The basics:
I have 1 odrive 24V v3.5 hooked up to a bench power supply and a raspberry pi w. The software installed and I ran the commands to edit my device rules. However I can’t find the device manually via lsusb, or in /dev, and odrivetool can’t find it ether. I double checked this with my laptop which also didn’t see the board and I double checked that the USB cable I was using was good by testing it with another device.

Prescribed testing:
I tried the following command as described here ( It did nothing but sit there as it also failed to find the odrive board.
odrivetool dfu

The green power light on the board is on and it is drawing > 20mA according to my power supply after things warm up. So it has power and it’s not hitting some kind of current limit. All the chips feel cool and no magic smoke has been emitted. So I believe the hardware to be in good working order. I have kept everything in an ESD safe environment but I suspect the board as never flashed at the factory.

What should I try next?


Is there more information I need to post to get feedback here? At the moment I don’t even have it hooked up to a motor of any kind or an encoder.

I manually flash all the boards before shipping them out. I do them one by one and it gets a bit repetitive; it is entirely possible I may have skipped one in the process.

You found the correct docs for flashing firmware. If you don’t have firmware on already, you need to follow the steps that are labeled “How to force DFU mode (ODrive v3.5)”.

Thanks the board responds now. I haven’t gotten it working yet but that is probably due to bugs in my understanding which is a work in progress.