USB Device not recognized

Good morning,

I am having issues with windows 10 not recognizing odrive properly. When i plug it in i get i get “USB Device not Recognized (Device descriptor request failed)” , in device manager it shows “Unknown USB Device (Device Descriptor Request Failed)”.

I have tried Zadig to load the libusb-win32 driver even though i am win64. Every time driver installation fails.

I have removed the USB device as well as my USB Root Hub and restarted with the same results. I have attempted to force windows to install the odrive cdc driver but no luck…

I have tried booting with the dip switch set to DFU mode, same results…

I have been able to re-flash the firmware using STLink-V2 and openocd using the downloaded firmware 3.5 24v, but no change in the USB connection issues. I have attempted to connect using odrivetool in Anaconda3 without success, therefore i cannot flash using odrivetool.

Due to the fact that i am new to python, i have attempted the Arduino interface as well with marginally more success. I was able to at least partially calibrate the motor, i get a quick short move at the beginning then a beep then the motor does a full rotation and stops. After this i am able to read the bus voltage and motor position but unable to send a test move - nothing happens.

Any help would be greatly appreciated, i have been searching the documentation and tried everything i can find with regards to the USB issue with no luck…

Best regards,


I am having literally the exact same issue. I am able to get the Arduino to communicate fine with the board but there is some setup that has to be done on the board before I can use the board for my project. Were you ever able to fix your issue? I know it has been almost a year since your post, but I am really confused.

Also, if anyone else has been able to figure this problem out since the original post, any help would be much appreciated.

I am also having the same issue as I connect my Odrive v3.6 48 V to my PC it responds that USB device not recognized. Is Creator of odrive is listening to our issue or not?

Where did you get this “ODrive v3.6 48V?”
ODrive v3.6 has two versions, which are labeled 24V and 56V. There are some boards advertised as “v3.6 48V” on sites like eBay, Alibaba, Taobao etc. but they are fakes. Some people have taken the design files for V3.4 and re-labeled it as v3.6, with poor quality manufacturing also.
You can’t expect the creator to provide support for ripped off versions.

Try plugging the ODrive into a Linux computer e.g. raspberry Pi, and use the command
sudo dmesg -w
to view diagnostics.

If you still get no USB connection even in DFU mode, then maybe the board has a faulty USB socket. Email with your order number and you should be able to get a replacement under warranty.

Oh sorry its 56V you’re right towen.