USB isolator, Ubuntu, Odrive connecting/disconnecting


We have an 56V Odrive connected (USB) to a Jetson Nano running Ubuntu to drive two hoverboards wheels.

We burned an Odrive because of ground loops. So we buyed a new one and now we want to use an USB Isolator.

We bought this USB isolator

Now if we connect the Odrive using the USB isolator, in the kernel logs the Odrive is always connecting and disconnecting and it also shows the message “failed to set dtr/rts”.

If we stop the ModemManager service the kernel stops connecting and disconnecting the Odrive (the dtr/rts message do not show) but as soon as we launch odrivetool the Odrive begins to connect/disconnect again.

Any advice to use the USB isolator with the Odrive in Ubuntu?


The USB isolator wil only work with an ODrive in 12 mbps mode. The ADuM3160 chip used in that device has two modes 1.5 Mbps and 12 Mbps, maybe there is a jumper hidden somewhere that allows you to select the mode?

1 Like

The USB isolator has no switch to select mode 1.5 or 12 Mbps

I have tried the USB isolator in windows with the Odrive and the issue of the usb connecting/disconnecting does not happen. So I guess the problem is something related with the Linux driver or how Linux manages usb connections.

Any suggestions?

1 Like

A screenshot of the kernel log when odrivetool is running (usb reconnection issue)

Hi fjam.

Are you running Linux on a Jetson Nano or Jetson TX2?
I have also had issues with USB isolators on nvidia jetson… My solution was to use CAN instead. :+1:
(actually, it worked for me without the USB isolator on the Jetson, but I used CAN for control anyway since it is so much more reliable, and just used USB for configuration)

1 Like

Hi towen,

I’m running Linux on a Jetson Nano.

I’m using usb because I think is easier. (No additional hardware)

Maybe the problem I’m facing is a bad connection between the USB isolator (the connector does not fit firmly in the port) and the USB port of the Nano. I’ll try to confirm if it is a bad contact between connectors,

Now the USB isolator works fine in Linux.
Seems that the port connection was the problem.
This type of USB isolator does not provide the more reliable connection.

Yes, they are quite bad for that.
If you have one of those short USB male-female cables that sometimes come with WiFi adapters etc, that will help a lot.

was this ever solved?