USB over-current error


I’m having problem connecting to the ODrive (version 3.6 56V). After powering up the ODrive and connecting USB to PC I’m getting following errors.

On Linux:

$ dmesg -w
device not accepting address 21, error -32
unable to enumerate USB device

According to this page it can mean that over-current protection was triggered.

On mac:

“USB Device disabled. Unplug the device using too much power to re-enable USB devices.”

When I try to connect using USB insulator, there is no dmesg output whatsoever. Voltage on 3V3 and 5V pins is correct. STM chip is not hot.

I have tried:

  • fw versions 0.5.1, 0.5.2 and 0.5.3
  • DFU and RUN mode
  • different power source
  • different micro USB cable

Board was purchased from

Am I doing something wrong?

How have you tried different firmware versions? Are you using an ST-Link, or does it enumerate on USB correctly when in DFU mode?

If it’s not working in DFU mode either (i.e. you have to use st-link to change firmware) then it’s likely a hardware issue with the board…
Check for continuity between the USB-A connector and the USB DM/DP pins of the STM chip. Check for short circuits between them, and between each and GND.

Probably, you can send it back for a free replacement if you email and link this thread.