V3.4 Step/Dir problem and fried board


I have been testing my ODrive v3.4 48v. The UART communication with arduino worked perfectly with two motors using the library example.

However, when testing step and direction with only one motor connected to M0 it worked perfectly but connecting a motor to M1 caused the M0 motor to step wildly. Ground was connected from Teensy 3.6 to J3 on ODrive, encoders cables are shielded.

Unfortunately before being able to further investigate, it seems that the board might have got fried, I am unable to flash the board and powering on with nothing connected causes the ARM to get hot.

ODrive v3.4 48v
CUI AMT102-V encoders
PropDrive 5060 270kv
24v Powersupply
Teensy 3.6 Microcontroller

Any help and insight into what might have gone wrong would be much appreciated.


That’s unfortunate, it is probably the case that a ground loop has injected current into the ARM GPIO pins and caused it to die. I know this won’t help you with your current situation, but we are adding some optional filters for step/dir input on ODrive v3.5, which will also help protect it from injection currents.

If you have the facilities to replace the ARM chip, then you can do that; it is this chip. Unfortunatly we are too small to have a repair serveice here, but I can give you a 40% discount on a replacement board if you want to simply purchase a replacement. Just DM me and I’ll give you a code.

To avoid ground loops in the future with v3.4 you can put some 3.3k resistors in series with the step/dir lines to try to mitigate any injection currents.

1 Like