V3.6 HoverboardMotor 56V

#1

Hey There,

I tried to get one of my Hoverboard wheels to work.
I followed this description https://docs.odriverobotics.com/hoverboard.html

If i try to do the Motor Calibration ( odrv0.axis0.requested_state = AXIS_STATE_MOTOR_CALIBRATION)

the Motor does not Move at all.

Error:
Axis0:
axis: Error(s): ERROR_MOTOR_FAILED
motor: Error(s): ERROR_PHASE_RESISTANCE_OUT_OF_RANGE encoder: no error
controller: no error

So i looked for a possible solution in the Topics here and tried

odrv0.axis0.motor.config.resistance_calib_max_voltage = 5

–> Motor moves a little bit

but Error is still the same.

So i tried odrv0.axis0.motor.config.requested_current_range = 20
Even no Succsess.

My Setup:
tested different Voltage Sources

  • 30V DC Supply 10A Rating (With and Without Buffering Caps)
  • 24V DC Supply 10A Rating (With and Without Buffering Caps)
  • 12V Lead Acid 80A Battery
  • 24V Lead Acid 80A Battery

Motor: Standart HoverBoad Hub Motor
–> measured Resistance between wires ~1.0 Ohm

Odrive V3.6 56V Version

Is there a Solution to get this Motor to a working State?

Thanks and kind Regards,

Steffen

0 Likes

#2

Maybe your phase resistance is actually out of range? Can you verify by unplugging the phase wires from the ODrive and measuring with a multimeter?

0 Likes

#3

Phase wire measurement with Multimeter was around 1.00 Ohm Phase to Phase.

Kind Regards,

Steffen

0 Likes

#4

Can you try the combination:

odrv0.axis0.motor.config.resistance_calib_max_voltage = 5
odrv0.axis0.motor.config.calibration_current = 5
1 Like

#5

I’ve got this kind of issues two days ago. Mine hubmotor was shortcircuited in one coil. Changed to another and everything is worked. I detected small difference between motors - not worked hubmotor rotated wery smooth without “clicks”. Working weel rotated with “clicks” wery well feeled with hand. For now i think may be some hubmotor colis wired as triangle not star.

0 Likes

#6

This Finally worked for me!
Thank you!

0 Likes