When I have set VEL_SETPOINT high, the motor just stopped WHY?

that is strange. I think my motor can run faster, but it won’t.
is anything wrong? and what can I do to solve it
the motor max 1500r/m

Maybe you are up against a voltage limit? What’s your DC Bus voltage and motor Kv?

DC Bus voltage 24V(now battery 23.3V)
motor Kv 24/36V

“24/36v” is not a motor constant that I recognise. :stuck_out_tongue:
It should be in RPM/V at no load, or Nm/A at stall.

Nevertheless, you should get about 80% of the “max speed at 24V”. If that’s 1500rpm, then you should be able to get 1200 rpm.
If the motor is actually rated at 1500rpm for 36V, then you will only get 800rpm.

Also check that motor.config.vel_limit is set high enough

yep ,sorry, my fault. it should be 1500RPM/24V
thanks. Let me check out vel_limit

Hi. towen😁
I thought about possible reasons what you said. and I am sure that vel_limit is high enough, however when I set vel set point high again,the motor stopped again. so I tried to set voltage limit higher,it’s still not working.
I’m just so sad
Maybe there is one another reason? What’s it?
I can’t figure it out.

what error do you get with dump_errors(odrv0) ?

I am using FW 0.4.12 and I get no error with odrv0.axis0.error

When the motor stopped,I could not set low vel_setpoint.And the motor began to get hot. If I do not turn the electricity off, the motor still gets hotter, even it is not running.

It sounds like you have the wrong encoder.config.cpr - if this is off by even 1 count, you will get a commutation error like this.

1 Like