Zadig and Win7 battle for supremacy

Ok, I have a slightly embarrassing chicken and egg problem.

I am following these instructions:

Use the Zadig utility to set ODrive driver to libusb-win32.

Check ‘List All Devices’ from the options menu, and select ‘ODrive 3.x Native Interface (Interface 2)’. With that selected in the device list choose ‘libusb-win32’ from the target driver list and then press the large ‘install driver’ button.

I plug in the ODrive and power it up and Zadig shows the device, but Win7 installs a driver before I can do anything (or Zadig fails to install if I try to do it really quickly)

Then from Device Manager I uninstall the driver, but Zadig won’t see it again until I unplug it and plug it back in, at which time, you guessed, Win7 installs a driver.

So is there any way to manually install the correct driver from Device Manager? Or tell Win7 not to install a driver?

The driver win7 installs doesn’t work:
usb.core.NoBackendError: No backend available



You shouldn’t need to uninstall the driver manually. Plug the ODrive in, let windows do it’s thing, then open Zadig. After listing all the devices and selecting the correct interface (Interface 2!), you can then select the libusb-win32 driver. The button below the driver selection may say “replace driver” or something similar.

The main point is that you can let windows install the driver, then use Zadig to replace the driver that windows installed.

1 Like

That’s got it - you have to go under Options and List All Devices.

Thanks @StrikeEagleCC!