Attribute gpio1_mode not found

It seems I have a problem with mapping the GPIO mode. The function gpio1_mode isn’t available.

Other posts on the forum discuss the same issue but don’t appear to solve my problem.

I wonder if it’s due to my firmware version, my ODrive Control Utility version, or something else.
I use an ODrive v3.6-56V, so my firmware version should be 0.5.6, but it shows that I am on firmware version 0.5.1. I tried to update the firmware using ‘odrivetool dfu’, but it seems I am already on the most recent version

Thanks for the support!

Try explicitly updating from a downloaded firmware version from this page: ODrive Releases

odrivetool dfu firmware.elf in that case

I tried that, but I’m not sure where to put the firmware.elf file in my folders for it to be detected by that function. Do I put it in my Python folder?

It’ll have to be put in the same folder as ODrivetool is being run from, yes. I believe on windows you can type cd to have the current path printed out.

1 Like

I believe I successfully updated with firmware.elf, but the gpio1_mode still shows as an undefined attribute. Is it possible that it’s not used and not necessary in this version? I tried to skip this step in the documentation, and it seems to work fine… probably why it’s not a problem.

All i did was:
odrv0.config.gpioX_analog_mapping.min = 0
odrv0.config.gpioX_analog_mapping.max = 20
odrv0.config.gpioX_analog_mapping.endpoint = odrv0.axis0.controller._input_vel_property

Thanks for the support!