Issue with testing the motor control after configuration

HI, I am using a 56V odrive v3.6 to control motors of the model turnigy sk8 6374 130kv. I have taken help from the documentation as well as some online resources to configure my motor and set the parameters. There were no errors which came up while doing this.

However, in the next step while testing the motor control, the motor wasn’t responding to the commands. I can feel slight vibration coming from the motor which I think means that it is getting power from the odrive.

I have done the configuration with command line once. And also tried doing it with a python script I found on github.

I am not from an electrical engineering background so I would be grateful for any steps I can follow or try out while fixing this issue as well as any other similar issues. Also I would be grateful if I could get help about the configuration values for this particular motor(turnigy sk8 6374 130kv) or a motor spec sheet if there is any.

link to python script for hardware configuration)
[GitHub - AustinOwens/odrive_config: Config scripts for configuring the BLDC ODrive Motor Controller]

Sources for the code I used configuring the motors

1 Like

Hi, I’m sorry to hear you’re having trouble with this. Lets get this figured out:

Which firmware version are you running?
What type of encoder are you using?
Can you please share the configuration you tried from the command line?
When you initially configured the ODrive, did this include motor and encoder calibration?
How are you sending commands to the ODrive, and which control / input mode are you using?

The python script provided is specifically for hoverboard motors, these require a few custom settings that are not appropriate for your motor(turnigy sk8 6374 130kv) so I wouldn’t suggest this as a reference. This video is pretty old as well, I would suggest sticking to the official documentation for the initial setup.

1 Like