M0 went up in smoke

Hello there

I am slowly getting crazy…

After I had trouble with my first board, I finally decided to get a new one and try to repare it when I have more time, the knowlege and the possibility to smt solder.

So I ordered a new board. After wiring, I finally plugged the battery in. First i did the usual beginner Tutorial to check if all worked. I noticed that the board was not running on the newest firmware. So I used pos.setpoint instead of input_pos. Not a big deal at all.

After that, I wantet to flash the current firmware. As the python dfu tool did not work again. I tried to do it manually.
I forced the Odrive in Dfu mode. But some time after I plugged the battery in, I noticed a white smoke comming out of M0. I immediately unplugged the battery. The motor did not heat up or anything.

I am using a Odrive 3.6 24V

With two 3s Lipos serial (23.54 V)

I am so frustrated. What may have caused this?
I guess, for now it means the end of my project until I get some money =(
welp

Were you flashing during this, or was it only in DFU mode? Before it failed, were you able to connect on USB? How long would you say the battery was plugged in before the smoke escaped?