Odrive not working anymore

I have a problem with an ODrive 56v I ordered on October 13.
It was connected to a 6384 bldc motor with a 24v battery and to a RPI3 using usb.
It worked ok for two days.
But last time I powered it on, the led just emitted light for 1 second then went black.
The ODrive is no more detected or flashable.

Each time I plug in the battery using xt90 connectors, the led emits lights for 1 second then goes black and
each time I plug out the battery it does the same thing: light for 1 sec.

I dismounted motor hall sensor and resistor and tried again.
But result is the same: Odrive not detected and led is off.

I measured the input voltage connectors and it reads 24v.

Do you know what is the problem and what I can do?

Thank you for your help.

Use a multimeter to measure the voltage between any of the 3.3V pins and GND. Do the same for 5V.
Also see if any of the chips are warm.

1 Like

I did the measurements:
all 3.3v measure 0.6v, and all 5v measure 1.5v.
I noticed no warm chip.

Do you have an idea of what happened?
Thank you for your help.

Is there anything still connected to the ODrive? e.g. an encoder?
Did you check the 3.3V regulator U3, on the back of the board behind the green power LED, to see if that is warm?

It’s possible that you had a ground loop, which in severe cases can damage the ODrive. Or possibly it was damaged by a severe inrush when you plugged it in. (although I’d expect the 56V odrive to be robust to anything a 24V battery can throw at it) Was there a loud spark?

What was happening when it first failed? Did you try to move a motor and the ODrive went off, or did you just plug it in (after it was previously working)?
What else was connected when you plugged it in?

If you have a bench power supply (with adjustable voltage and current limit), we can probably find out which component has failed, and if you are confident with a hot air SMD rework station you could replace it, but I’d probably advise to email info@odriverobotics.com first and see if you can get a replacement under warranty.

Thank you for your answer Towen

No, I unplugged everything motor/encoder/resistor.
I checked U3: 1.5v in /0.56v out
I didn’t saw any spark.

What was happening when it first failed?

You will laugh.
I was trying an usb isolator i just received to prevent possible ground loop as advised on https://docs.odriverobotics.com/ground-loops.html
But I think that it wasn’t necessary as Odrive was powered by battery and RPI3 was powered by power supply/mains.

I already sent a message to info@odriverobotics.com.
I’m waiting for an answer.

1 Like

I received no answer from email support.
Is there somebody from the staff there?
Thank you

Try messaging @madcowswe or @PJohnson

Hi Fabien, I’m sorry about the delay, I will follow up with them.

Thank you towen & Wetmelon,
Odrive support emailed me and kindly offered to replace the board.

1 Like

This could well be down to inrush current damage.
I killed 2 oDrives before I realised what the issue was. They worked fine for many power cycles before they died.
The damage on both boards shorted the 4 MOSFETS (48V to Ground) on A for Axis 1. It also killed U4, U3, U8 and in one case also U2. Is a lot of work to repair them and you need a hot air gun.
If you have similar damage then the easiest solution is probably a precharge circuit:

1 Like

Agreed… See also

Althouigh a simpler solution might be to use XT90-S connectors. :slight_smile:

1 Like

Thank you @ARRevolution an @towen.
I will change my connectors to XT90-S.
I don’t want to burn my replacement board.

1 Like