Sorry guys trying to update a 3.6 56v

Hi guys stupid question.
Trying to update to version 0.5.6 and can’t find hex files, only elf.
Yet on your docs it says to use hex.
Am I not understanding something.
Also what version of the gui works with the v3.6 .

Thanks in advance.

Hey there,

You should be able to update automatically using ODrivetool just through odrivetool dfu – this’ll automatically fetch the newest firmware.

Unfortunately, the GUI is only compatible with new-generation ODrive devices (ODrive Pro and S1 at the moment), not v3.6. Apologies for the inconvenience.

Tried that several times doesn’t do anything. That’s why I was looking at the hex files.
Which don’t seem to be there.

What happens when you run odrivetool dfu? Do you mean it doesn’t update the firmware to a newer version? Or just nothing happens when you run it?

Same as when I first got it ,nothing .
I type the line in and nothing.
Hence why I was trying to get hex file to manually put it in dfu and use the tool that was provided with kit.
This odrive is over two years old and has the v0.5.1 firmware running on it.
That’s what it came with.

Have you tried running the odrivetool dfu command after flipping the RUN/DFU switch on the board to “DFU” and then power cycling the board?

I’ll try again.
I have seen a tutorial on using Ubuntu install.
So using the Linux but I haven’t gone that far.
I did try and run my linear tubular bldc motor and got asfar as a red flag on calibrating cycle.
That’s on me though.
I definitely have to try a dual differential line receiver.
It seems to be missing the index point at the end of the strip.
Or I just put end stops at that point.
It comes back on red flag as ppr magnet pole pitch miss alignment.

It doesn’t stop at end of strip , just bounces off end and goes back the other way.

This could be just binding of bearings or friction in the system.

So again on me.
I have a long way to go.

It comes up as syntax error.
With the dfu switch on and off.
That’s coppied from your docs.

Can you please show me the exact command and output? It’s much more helpful if you can post a screenshot of the console output – there’s not much way I can help otherwise.

It’s OK now.
I had a friend who is a programmer sort out the conflict.its updated now.

Ive since found that the index mark on the magnetic strip for linear encoder doesn’t exsist.

Trying to work out how to do full calibration sequence using endstops as set boundaries.

It seems to want to do multiple turns.

Of course linear motors can’t.

Is it possible to set the mechanical pole pitch of the motor , and the magnets
Eg 45 mm, then set your boundary length.

Has someone already done this.